본문 바로가기
Linux

PHP 5.3 이상 Zend Guard Loader 설치

by 씨엔아이소프트 2019. 11. 2.
반응형

PHP 5.3 이상에서는 Zend Optimizer 가 아닌 Zend Guard Loader 라는 이름으로 배포됨

PHP 버전에 맞게 다운로드

 

- Zend Guard Loader (Runtime for PHP 5.4) 64-bit:

http://downloads.zend.com/guard/6.0.0/ZendGuardLoader-70429-PHP-5.4-linux-glibc23-x86_64.tar.gz

 

- Zend Guard Loader (Runtime for PHP 5.4) 32-bit:

http://downloads.zend.com/guard/6.0.0/ZendGuardLoader-70429-PHP-5.4-linux-glibc23-i386.tar.gz

 

- Zend Guard Loader (Runtime for PHP 5.3) 64-bit:

http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-x86_64.tar.gz

 

- Zend Guard Loader (Runtime for PHP 5.3) 32-bit:

http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz

 

 

# wget http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-x86_64.tar.gz

# tar zxvf ZendGuardLoader-php-5.3-linux-glibc23-x86_64.tar.gz

 

압축이 풀린 디렉토리 안에 php-5.3 안에 ZendGuardLoader.so 파일을 

32비트인 경우 /usr/lib/php/modules

64비트는 /usr/lib64/php/modules 로 이동 

 

/etc/php.d/ZendGuard.ini 파일 생성

# vi /etc/php.d/ZendGuard.ini

; Enable Zend Guard extension

zend_extension=/usr/lib/php/modules/ZendGuardLoader.so

zend_loader.enable=1

if your server is 64-bit then use:

 

- 64비트인 경우

; Enable Zend Guard extension

zend_extension=/usr/lib64/php/modules/ZendGuardLoader.so

zend_loader.enable=1

 

웹 서버 재시작

# /etc/init.d/httpd restart  

 

# php -v

Cannot load Zend Extension Manager - it was built with configuration 1.2.0, whereas running engine is API220090626,NTS

PHP 5.3.3 (cli) (built: Dec 11 2013 03:29:57)

Copyright (c) 1997-2010 The PHP Group

Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

 

반응형

댓글0